Menu
Call of Duty: Black Ops 4
Call of Duty: Black Ops 4
Release Date: 2018. October 12. (PC)
Sys. Reqs.: Average (41/70)
Popularity: 6# ■
Genre: Action, FPS
Developer: Treyarch
Publisher: Activision
iThere are only official system requirements on the site which are released by developers or an official publisher.
Minimum system requirements:
Recommended system requirements:
CPU:
Intel Core i5 2500k or AMD equivalent
CPU:
Intel Core i7 4770k or AMD equivalent
RAM:
8 GB RAM
RAM:
12 GB RAM
GPU:
Nvidia GeForce GTX 660 2 GB / GTX 1050 2GB or AMD Radeon HD 7850
GPU:
Nvidia GeForce GTX 970 / GTX 1060 6GB or AMD Radeon R9 390 / AMD RX 580
DX:
Version 11.0 compatible video card or equivalent
DX:
Version 11.0 compatible video card or equivalent
OS:
Windows 7 64-Bit or later http://gamesystemrequirements.com/
OS:
Windows 10 64 Bit
Store:
25GB HD space
Store:
25GB HD space
Sound:
DirectX Compatible
Sound:
DirectX Compatible
Network:
Broadband Internet connection
Network:
Broadband Internet connection
Note: Beta system requirements
Comparison:
Compare the system requirements with a configuration added by you.
Videos:
Call of Duty: Black Ops 4 - Launch Gameplay TrailerCall of Duty: Black Ops 4 - Zombies IX Music VideoCall of Duty: Black Ops 4 - Blackout Battle Royale TrailerCall of Duty: Black Ops 4 - PC Trailer
Similar games:
Call of Duty: Black Ops IIRAGESquadHalf-Life 2
Post Comment
Please login to post a comment.
Comments: 88
no avatar
27 days ago | 2018. 08. 28. 11:49:50
#
I have i7 8700k
Gtx 1060
Ram 16 gb
Can i run it on 4k +40 fps????
no avatar
29 days ago | 2018. 08. 26. 15:17:56
#
Intel Core i3- 5005U
8 GB Ram
Intel HD Graphics 5500 4GB

Can Run
bagusprs avatar
28 days ago | 2018. 08. 27. 03:38:13
#
no... it would probably lag or unplayable..
no avatar
41 days ago | 2018. 08. 14. 22:52:22
#
Can i run black ops 4 no:
Amd a10-4600 2.3ghz (up to 3.2ghz)
Vga amd radeon 7660g
Ram 8gb
boy7nine avatar
66 days ago | 2018. 07. 20. 18:44:17
#
;)
Vote
Are you planning to exchange your CPU for an AMD Ryzen processor?






You must log in to vote.