Game System Requirements Google+ profile
Game System Requirements Google+ profile
Game System Requirements Google+ profile
Game System Requirements Facebook profile
Name
Passw.
Stay signed in
Need For Speed Underground
8.5
Need For Speed Underground
Release Date: 2003. November 17. (PC)
Popularity: ~360# ■
Genre: Racing
Developer: EA Black Box
Publisher: Electronic Arts
iThere are only official system requirements on the site which are released by developers or an official publisher.
Minimum system requirements:
Recommended system requirements:
CPU:
Intel Pentium III (or compatible) CPU running at 700Mhz or higher
CPU:
Intel Pentium III (or compatible) CPU running at 700Mhz or higher
RAM:
128MB of RAM (256 MB using Windows 2000 or XP)
RAM:
256MB of RAM
GPU:
32MB DirectX 9 compatible video card (Geforce2 or higher) using a supported chipset (see below)
GPU:
32MB DirectX 9 compatible video card (Geforce2 or higher) using a supported chipset (see below)
DX:
DirectX 9
DX:
DirectX 9
OS:
Windows 98, 98 Second Edition, ME, 2000 Professional, XP Professional, or XP Home operating system
OS:
Windows 98, 98 Second Edition, ME, 2000 Professional, XP Professional, or XP Home operating system
Store:
450 MB free Hard Disk space, plus space for Direct X9
installation.
Store:
450 MB free Hard Disk space, plus space for Direct X9 installation
Sound:
DirectX compatible sound card
Sound:
DirectX compatible Sound Card
ODD:
8X CD-ROM
ODD:
8X CD-ROM
Network:
Network card for broadband connectivity
Note: * Supported Video Card Chipsets: * ATI Radeon 7500 or greater * Intel i865 * Matrox Parhelia * NVidia geForce2 or greater * SiS Xabre 400
The game's system requirements are extremely low that's why making a comparison is not feasible.
Similar games:
RAGEGrid AutosportNeed For Speed ShiftCar Mechanic Simulator 2015F1 2015
Post Comment
Please login to post a comment.
Comments: 1
Attila-13 avatar
2012. 01. 20. 23:32:42 #
 
100/100
It was a great game when it was released! :D
Vote
How much do you spend per month on video games?










You must log in to vote.