header
LEGO Harry Potter: Years 1-4
LEGO Harry Potter: Years 1-4 cover
Release date: 2010. June 25.
Genre: Action, Adventure
Developer: TT Games
Publisher: Warner Bros. Interactive Entertainment

LEGO Harry Potter: Years 1-4 System Requirements

Minimum system requirements:

CPU:
Intel P4 1.8 GHz/AMD Athlon XP 2200+
RAM:
512 MB RAM
GPU:
ATI X1300/NVIDIA GeForce FX 5800 (256 MB RAM)
OS:
Windows XP/Vista
Sound:
100% DirectX®9.0c compatible audio device

Recommended system requirements:

CPU:
Intel Core 2 Duo/AMD Athlon 64, 2.8GHz
RAM:
2 GB RAM
GPU:
ATI HD 2900/NVIDIA GeForce 8800
OS:
Windows XP/Vista
Sound:
100% DirectX®9.0c compatible audio device
Recommended peripheral: Keyboard; Xbox 360 Controller for Windows supported
There are only official system requirements on the site which are released by developers or an official publisher.
Can you run it?
Compare the system requirements with a configuration you can add below.
Please support our site in order to make further progress!
SUPPORT US
Similar games:
Drake HollowTowerClimbHalf DeadHolobunnies: Pause CaféWatch Dogs: LegionDrug Dealer Simulator
Comments: 1
Please login to post a comment.
no avatar
This is what i have found:

Lego Harry Potter: Years 1-4
System Requirements*
Intel Processor - Core 2 Duo E6400 2.13GHz
AMD Processor - Athlon 64 X2 Dual Core 4800+
Nvidia Graphics Card - Geforce 8600 GTS 512MB
ATI Graphics Card - Radeon HD 5570
RAM Memory - 1 GB
Hard Disk Space - 4.5 GB
Direct X - 9
* System requirements displayed are based on recommended system requirements and should be used as a guide only.
0
0
0
0


Forgotten passwordRegister