Overlord: Fellowship of Evil
Release date: 2015. October 20. (PC)
Genre: Action, Adventure
Developer: Codemasters
Publisher: Codemasters

Overlord: Fellowship of Evil System Requirements

Minimum system requirements:

CPU:
Intel Core 2 Duo E4600 or AMD Athlon x2 5400+
RAM:
2 GB RAM
GPU:
AMD HD4870 or Nvidia GTX280
OS:
Windows Vista, Windows 7 or Windows 8
STO:
4 GB available space
Sound:
DirectX Compatible soundcard
NET:
Broadband Internet connection

Recommended system requirements:

CPU:
AMD FX Series or Intel Core i5 Series
RAM:
4 GB RAM
GPU:
AMD R9 270 or Nvidia GTX660
OS:
Windows Vista, Windows 7 or Windows 8
STO:
4 GB available space
Sound:
Direct X compatible soundcard
There are only official system requirements on the site which are released by developers or an official publisher.
Can you run it?
Compare the system requirements with a configuration you can add below.
Please support our site in order to make further progress!
SUPPORT US
Similar games:
Catherine ClassicTrine 2: Complete StoryGrand Theft Auto IIIBATTLETECHARK: Survival EvolvedDGU
Comments
Please login to post a comment.
No comments have been posted. Be the first to comment!


Forgotten passwordRegister