header
Gotham City Impostors
Gotham City Impostors cover
Release date: 2012. February 07.
Genre: Action, FPS
Developer: Monolith Productions
Publisher: Warner Bros. Interactive Entertainment

Gotham City Impostors System Requirements

Minimum system requirements:

CPU:
Dual Core CPU 2.5 GHz
RAM:
1.5 GB RAM
GPU:
256MB dedicated memory DX9 Video Card (GeForce 8600 or ATI X1800 or better)
DX:
DX9.0c
OS:
Windows XP SP3
STO:
7 GB Hard Drive Space
Sound:
DX9 Compatible Sound Controller
NET:
Broadband Internet Connection

Recommended system requirements:

CPU:
Quad Core CPU 2 GHz
RAM:
2GB RAM
GPU:
512MB DX9 High-Performance Video Card (GeForce 8800 or ATI X1900 or better)
DX:
DX9.0c
OS:
Windows 7
STO:
7 GB Hard Drive Space
Sound:
DX9 Compatible Sound Controller
NET:
Broadband Internet Connection
There are only official system requirements on the site which are released by developers or an official publisher.
Can you run it?
Compare the system requirements with a configuration you can add below.
Similar games:
PAYDAY 2ScatheRAGESuper Death ArenaTom Clancy's Ghost Recon PhantomsLeft 4 Dead 2
Comments: 1
Please login to post a comment.
lazarus avatar
funny game with crazy dudes 😀
0
0
0
0


Forgotten passwordRegister