header
Panzer Elite Action
Panzer Elite Action cover
Release date: 2007. April 20.

Panzer Elite Action System Requirements

Minimum system requirements:

CPU:
PIII 800Mhz or AMD Duron 800Mhz or faster x86 compatible
RAM:
256Mb [DDRAM] or more
GPU:
ATI Radeon 8500 or nVidia GeForce 3 Ti (must support ps.1.1) with at least 32Mb of video memory
DX:
DirectX 9.0 or newer
OS:
Windows XP
STO:
3Gb or more free disk space
Sound:
[optional] Sound card

Recommended system requirements:

CPU:
P4 2.0Ghz or AMD XP 2400+ or greater x86 or AMD64 processor.
RAM:
1Gb of fast DDRAM (PC3200 recommended)
GPU:
ATI 9800XT or nVidia 6600Gt with 256Mb of video memory
DX:
DirectX 9.0c
OS:
Windows XP with service pack 2 and updates
STO:
3Gb or more free disk space
Sound:
Sound card with 5.1 or 7.1 support (Audigy2 recommended)
There are only official system requirements on the site which are released by developers or an official publisher.
Making a comparison is not available for this game.
Similar games:
Real BoxingDespot's GameMarvel's AvengersMount & BladeHalf-LifeHolobunnies: The Bittersweet Adventure
Comments
Please login to post a comment.
No comments have been posted. Be the first to comment!


Forgotten passwordRegister