header
We Need to Go Deeper
We Need to Go Deeper cover
Release date: 2017. February 08.
Genre: Action
Developer: Deli Interactive
Publisher: Deli Interactive

We Need to Go Deeper System Requirements

Minimum system requirements:

CPU:
Intel® Core™ i5-2450M Processor (3M Cache, up to 3.10 GHz) or Better
RAM:
4 GB RAM
GPU:
Intel(R) HD Graphics 3000 or better
DX:
Version 9.0c
OS:
Windows Vista or Later
STO:
1400 MB available space
There are only official system requirements on the site which are released by developers or an official publisher.
Can you run it?
Compare the system requirements with a configuration you can add below.
Similar games:
Samurai Sword VRDRAGON BALL FighterZGUILTY GEAR Xrd -SIGN-LEFT ALIVEMinoriaThe Tower Of Elements
Comments
Please login to post a comment.
No comments have been posted. Be the first to comment!


Forgotten passwordRegister