no header
Scooby-Doo! and the Spooky Swamp
Release date: 2012. November 30.

Scooby-Doo! and the Spooky Swamp System Requirements

Minimum system requirements:

CPU:
Intel Pentium 4, 2 GHz
RAM:
512 MB (XP) 2 GB (Vista / 7)
GPU:
NVIDIA GeForce 6200 / ATI Radeon 9600
DX:
DirectX 9.0c
OS:
Windows XP / Vista / 7
STO:
2 GB
Sound:
DirectX 9.0c compatible soundcard
ODD:
DVD-ROM x8
Recommended peripheral: Mouse, Keyboard, Xbox 360 compatible gamepad
There are only official system requirements on the site which are released by developers or an official publisher.
Making a comparison is not available for this game.
Similar games:
Homefront: The RevolutionPostal 2Megamagic: Wizards of the Neon AgeBurly Men at SeaSerious Sam Classics: RevolutionProject 5: Sightseer
Comments
Please login to post a comment.
No comments have been posted. Be the first to comment!


Forgotten passwordRegister